All systems operational

GLS carrier update

Completed
Scheduled for 25. Apr 2024 at 19:00 – 19:23

Affects

Balíkobot
Shippers
GLS
Updates
  • Completed
    25. Apr 2024 at 19:23
    Completed
    25. Apr 2024 at 19:23

    The Geis transport update is complete.

  • In progress
    25. Apr 2024 at 19:00
    In progress
    25. Apr 2024 at 19:00
    Maintenance is now in progress
  • Planned
    25. Apr 2024 at 19:00
    Planned
    25. Apr 2024 at 19:00
    We are planning for a scheduled maintenance during that time.